// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m).*<p class="amigo">(?s)(?-s)(.*)<br>*$"#).unwrap();
let string = "<p class=\"amigo\">My mother is at home.<p>
afasf
<p class=\"amigo\">My mother is at home.<br>
asfa
asffa
<p class=\"amigo\">My mother is at home.<p>
asdas";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}