import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*<p class=\"amigo\">(?s)(?-s)(.*)<br>*$";
final String string = "<p class=\"amigo\">My mother is at home.<p>\n\n\n"
+ "afasf\n\n"
+ "<p class=\"amigo\">My mother is at home.<br>\n\n"
+ "asfa\n\n"
+ "asffa\n\n"
+ "<p class=\"amigo\">My mother is at home.<p>\n\n"
+ "asdas";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}