re = /.*<p class="amigo">(?s)(?-s)(.*)<br>*$/m
str = '<p class="amigo">My mother is at home.<p>
afasf
<p class="amigo">My mother is at home.<br>
asfa
asffa
<p class="amigo">My mother is at home.<p>
asdas'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end