using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(([^()]|(?R))*\)";
string input = @"ok, d(*, 10), hmmm, ok, d(*, 10), hmmm
a, b, c(1,3,4(nest)) d, ok(bruh)
aa(aa)aaaa)(aa(aa(aa)aa)aaaa(aa(aa(aa)aa)aa)aaaaaa(aa(aa(aa(aa)aa)aa)aa)aa
arg, nested(arg2, another(ok)), arg3, call(this)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}