re = /\(([^()]|(?R))*\)/m
str = 'ok, d(*, 10), hmmm, ok, d(*, 10), hmmm
a, b, c(1,3,4(nest)) d, ok(bruh)
aa(aa)aaaa)(aa(aa(aa)aa)aaaa(aa(aa(aa)aa)aa)aaaaaa(aa(aa(aa(aa)aa)aa)aa)aa
arg, nested(arg2, another(ok)), arg3, call(this)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end