import re
regex = re.compile(r"\(([^()]|(?R))*\)", flags=re.MULTILINE)
test_str = ("ok, d(*, 10), hmmm, ok, d(*, 10), hmmm\n"
"a, b, c(1,3,4(nest)) d, ok(bruh)\n\n"
"aa(aa)aaaa)(aa(aa(aa)aa)aaaa(aa(aa(aa)aa)aa)aaaaaa(aa(aa(aa(aa)aa)aa)aa)aa\n\n"
"arg, nested(arg2, another(ok)), arg3, call(this)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")