use strict;
my $str = 'ok, d(*, 10), hmmm, ok, d(*, 10), hmmm
a, b, c(1,3,4(nest)) d, ok(bruh)
aa(aa)aaaa)(aa(aa(aa)aa)aaaa(aa(aa(aa)aa)aa)aaaaaa(aa(aa(aa(aa)aa)aa)aa)aa
arg, nested(arg2, another(ok)), arg3, call(this)
';
my $regex = qr/\(([^()]|(?R))*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}