// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(([^()]|(?R))*\)").unwrap();
let string = "ok, d(*, 10), hmmm, ok, d(*, 10), hmmm
a, b, c(1,3,4(nest)) d, ok(bruh)
aa(aa)aaaa)(aa(aa(aa)aa)aaaa(aa(aa(aa)aa)aa)aaaaaa(aa(aa(aa(aa)aa)aa)aa)aa
arg, nested(arg2, another(ok)), arg3, call(this)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}