package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(([^()]|(?R))*\)`)
var str = `ok, d(*, 10), hmmm, ok, d(*, 10), hmmm
a, b, c(1,3,4(nest)) d, ok(bruh)
aa(aa)aaaa)(aa(aa(aa)aa)aaaa(aa(aa(aa)aa)aa)aaaaaa(aa(aa(aa(aa)aa)aa)aa)aa
arg, nested(arg2, another(ok)), arg3, call(this)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}