# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*\([A-Z]{3}\K(?=\))/\n/gm;t' <<< "Intel(USA)
Pfizer(USA)6
GeneralElectric(USA)43
Alphabet(Google)(USA)"