const regex = /^.*\([A-Z]{3}\K(?=\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\([A-Z]{3}\\K(?=\\))', 'gm')
const str = `Intel(USA)
Pfizer(USA)6
GeneralElectric(USA)43
Alphabet(Google)(USA)`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);