use strict;
my $str = 'Intel(USA)
Pfizer(USA)6
GeneralElectric(USA)43
Alphabet(Google)(USA)';
my $regex = qr/^.*\([A-Z]{3}\K(?=\))/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";