re = /^.*\([A-Z]{3}\K(?=\))/m
str = 'Intel(USA)
Pfizer(USA)6
GeneralElectric(USA)43
Alphabet(Google)(USA)'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result