using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\([A-Z]{3}\K(?=\))";
string substitution = @"\n";
string input = @"Intel(USA)
Pfizer(USA)6
GeneralElectric(USA)43
Alphabet(Google)(USA)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}