import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\([A-Z]{3}\\K(?=\\))";
final String string = "Intel(USA)\n"
+ "Pfizer(USA)6\n"
+ "GeneralElectric(USA)43\n"
+ "Alphabet(Google)(USA)";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}