#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\W*(?i)\b(?<!\.)(?!GOOD_DATABASE)\w+[.]\S*(?-i)\W*"
Local $sString = "SELECT" & @CRLF & _
"COL1," & @CRLF & _
"COl2," & @CRLF & _
"COL3" & @CRLF & _
"" & @CRLF & _
"FROM GOOD_DATABASE.SCHEMA1.TAB1 table1" & @CRLF & _
"" & @CRLF & _
"JOIN GOOD_DATABASE.SCHEMA2.TAB2 table2" & @CRLF & _
"" & @CRLF & _
"JOIN BAD_DATABSE.SCHEMA1.TAB3" & @CRLF & _
"" & @CRLF & _
"JOIN BAD_DATABASE.SCHEMA3.TAB4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")