using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\W*(?i)\b(?<!\.)(?!GOOD_DATABASE)\w+[.]\S*(?-i)\W*";
string input = @"SELECT
COL1,
COl2,
COL3
FROM GOOD_DATABASE.SCHEMA1.TAB1 table1
JOIN GOOD_DATABASE.SCHEMA2.TAB2 table2
JOIN BAD_DATABSE.SCHEMA1.TAB3
JOIN BAD_DATABASE.SCHEMA3.TAB4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}