import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\W*(?i)\\b(?<!\\.)(?!GOOD_DATABASE)\\w+[.]\\S*(?-i)\\W*";
final String string = "SELECT\n"
+ "COL1,\n"
+ "COl2,\n"
+ "COL3\n\n"
+ "FROM GOOD_DATABASE.SCHEMA1.TAB1 table1\n\n"
+ "JOIN GOOD_DATABASE.SCHEMA2.TAB2 table2\n\n"
+ "JOIN BAD_DATABSE.SCHEMA1.TAB3\n\n"
+ "JOIN BAD_DATABASE.SCHEMA3.TAB4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}