use strict;
my $str = 'SELECT
COL1,
COl2,
COL3
FROM GOOD_DATABASE.SCHEMA1.TAB1 table1
JOIN GOOD_DATABASE.SCHEMA2.TAB2 table2
JOIN BAD_DATABSE.SCHEMA1.TAB3
JOIN BAD_DATABASE.SCHEMA3.TAB4';
my $regex = qr/\W*(?i)\b(?<!\.)(?!GOOD_DATABASE)\w+[.]\S*(?-i)\W*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}