const regex = /\W*(?i)\b(?<!\.)(?!GOOD_DATABASE)\w+[.]\S*(?-i)\W*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\W*(?i)\\b(?<!\\.)(?!GOOD_DATABASE)\\w+[.]\\S*(?-i)\\W*', 'gm')
const str = `SELECT
COL1,
COl2,
COL3
FROM GOOD_DATABASE.SCHEMA1.TAB1 table1
JOIN GOOD_DATABASE.SCHEMA2.TAB2 table2
JOIN BAD_DATABSE.SCHEMA1.TAB3
JOIN BAD_DATABASE.SCHEMA3.TAB4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}