import Foundation
let pattern = #"\W*(?i)\b(?<!\.)(?!GOOD_DATABASE)\w+[.]\S*(?-i)\W*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SELECT
COL1,
COl2,
COL3
FROM GOOD_DATABASE.SCHEMA1.TAB1 table1
JOIN GOOD_DATABASE.SCHEMA2.TAB2 table2
JOIN BAD_DATABSE.SCHEMA1.TAB3
JOIN BAD_DATABASE.SCHEMA3.TAB4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)