re = /\W*(?i)\b(?<!\.)(?!GOOD_DATABASE)\w+[.]\S*(?-i)\W*/m
str = 'SELECT
COL1,
COl2,
COL3
FROM GOOD_DATABASE.SCHEMA1.TAB1 table1
JOIN GOOD_DATABASE.SCHEMA2.TAB2 table2
JOIN BAD_DATABSE.SCHEMA1.TAB3
JOIN BAD_DATABASE.SCHEMA3.TAB4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end