#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)//[^\r\n]*(*SKIP)(*F)|background:\s*(?!transparent|none)\w+"
Local $sString = "background: #fff; // should not be found" & @CRLF & _
"background: transparents; // should not be found, but is found" & @CRLF & _
"// background: blue; background: blue; // should be found" & @CRLF & _
"background: blue;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")