use strict;
my $str = 'background: #fff; // should not be found
background: transparents; // should not be found, but is found
// background: blue; background: blue; // should be found
background: blue;';
my $regex = qr@//[^\r\n]*(*SKIP)(*F)|background:\s*(?!transparent|none)\w+@mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}