import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "//[^\\r\\n]*(*SKIP)(*F)|background:\\s*(?!transparent|none)\\w+";
final String string = "background: #fff; // should not be found\n"
+ "background: transparents; // should not be found, but is found\n"
+ "// background: blue; background: blue; // should be found\n"
+ "background: blue;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}