const regex = new RegExp('//[^\\r\\n]*(*SKIP)(*F)|background:\\s*(?!transparent|none)\\w+', 'gm')
const str = `background: #fff; // should not be found
background: transparents; // should not be found, but is found
// background: blue; background: blue; // should be found
background: blue;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}