$re = '@//[^\r\n]*(*SKIP)(*F)|background:\s*(?!transparent|none)\w+@m';
$str = 'background: #fff; // should not be found
background: transparents; // should not be found, but is found
// background: blue; background: blue; // should be found
background: blue;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);