using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"//[^\r\n]*(*SKIP)(*F)|background:\s*(?!transparent|none)\w+";
string input = @"background: #fff; // should not be found
background: transparents; // should not be found, but is found
// background: blue; background: blue; // should be found
background: blue;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}