#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https?://(mobile\.|www\.)?(twitter|x)\.com([\w/-]+)"
Local $sString = "https://twitter.com/lorem↵" & @CRLF & _
"https://www.twitter.com/ipsum↵" & @CRLF & _
"https://x.com/dolor↵" & @CRLF & _
"https://mobile.x.com/sit↵" & @CRLF & _
"https://fedex.com/amet↵" & @CRLF & _
"https://www.fedex.com/consectetur"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")