// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https?://(mobile\.|www\.)?(twitter|x)\.com([\w/-]+)").unwrap();
let string = "https://twitter.com/lorem↵
https://www.twitter.com/ipsum↵
https://x.com/dolor↵
https://mobile.x.com/sit↵
https://fedex.com/amet↵
https://www.fedex.com/consectetur";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}