re = /https?:\/\/(mobile\.|www\.)?(twitter|x)\.com([\w\/-]+)/
str = 'https://twitter.com/lorem↵
https://www.twitter.com/ipsum↵
https://x.com/dolor↵
https://mobile.x.com/sit↵
https://fedex.com/amet↵
https://www.fedex.com/consectetur'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end