use strict;
my $str = 'https://twitter.com/lorem↵
https://www.twitter.com/ipsum↵
https://x.com/dolor↵
https://mobile.x.com/sit↵
https://fedex.com/amet↵
https://www.fedex.com/consectetur';
my $regex = qr/https?://(mobile\.|www\.)?(twitter|x)\.com([\w/-]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}