$re = '/https?://(mobile\.|www\.)?(twitter|x)\.com([\w/-]+)/';
$str = 'https://twitter.com/lorem↵
https://www.twitter.com/ipsum↵
https://x.com/dolor↵
https://mobile.x.com/sit↵
https://fedex.com/amet↵
https://www.fedex.com/consectetur';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);