#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[\s,]*[-*/+\d]+"
Local $sString = "quanity*price/2+tax" & @CRLF & _
"quanity*price/2" & @CRLF & _
"quanity , *price/2+tax" & @CRLF & _
"quanity - *price,/2" & @CRLF & _
"quanity -, -- , *price,/2" & @CRLF & _
"quantity - 3 //,,/price"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)