import re
regex = re.compile(r"[\s,]*[-*/+\d]+", flags=re.MULTILINE)
test_str = ("quanity*price/2+tax\n"
"quanity*price/2\n"
"quanity , *price/2+tax\n"
"quanity - *price,/2\n"
"quanity -, -- , *price,/2\n"
"quantity - 3 //,,/price")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)