package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\s,]*[-*/+\d]+`)
var str = `quanity*price/2+tax
quanity*price/2
quanity , *price/2+tax
quanity - *price,/2
quanity -, -- , *price,/2
quantity - 3 //,,/price`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}