const regex = new RegExp('[\\s,]*[-*/+\\d]+', 'gm')
const str = `quanity*price/2+tax
quanity*price/2
quanity , *price/2+tax
quanity - *price,/2
quanity -, -- , *price,/2
quantity - 3 //,,/price`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);