using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s\b(\d*[a-z]\d*){1,2}\b)|(\s\b\d+\b)";
string substitution = @"";
string input = @"abcd abc ad1r ab a11b a1 11a 1111 1111abcd";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}