import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s\\b(\\d*[a-z]\\d*){1,2}\\b)|(\\s\\b\\d+\\b)";
final String string = "abcd abc ad1r ab a11b a1 11a 1111 1111abcd";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}