const regex = /(\s\b(\d*[a-z]\d*){1,2}\b)|(\s\b\d+\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s\\b(\\d*[a-z]\\d*){1,2}\\b)|(\\s\\b\\d+\\b)', 'g')
const str = `abcd abc ad1r ab a11b a1 11a 1111 1111abcd`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);