re = /(\s\b(\d*[a-z]\d*){1,2}\b)|(\s\b\d+\b)/
str = 'abcd abc ad1r ab a11b a1 11a 1111 1111abcd'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result