$re = '/(\s\b(\d*[a-z]\d*){1,2}\b)|(\s\b\d+\b)/';
$str = 'abcd abc ad1r ab a11b a1 11a 1111 1111abcd';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;