// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\s\b(\d*[a-z]\d*){1,2}\b)|(\s\b\d+\b)").unwrap();
let string = "abcd abc ad1r ab a11b a1 11a 1111 1111abcd";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}