using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s{8}/.*?(/.*?)?/(.*?):\d+\s{$";
string input = @"ltm pool /Common/ActiveDirectory_Pool {
members {
/Common/hodcdcgw01:389 {
address 10.6.15.21
priority-group 3
}
/Common/hodcdcgw02:389 {
address 10.6.15.22
priority-group 3
}
/Common/hodcdcgw04-1:389 {
address 10.6.15.207
priority-group 3
}
/Common/wkdcadrw02:389 {
address 10.6.66.21
priority-group 1
}
}
min-active-members 1
monitor /Common/bmdp_tcp
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}