import re
regex = re.compile(r"^\s{8}/.*?(/.*?)?/(.*?):\d+\s{$", flags=re.MULTILINE)
test_str = ("ltm pool /Common/ActiveDirectory_Pool {\n"
" members {\n"
" /Common/hodcdcgw01:389 {\n"
" address 10.6.15.21\n"
" priority-group 3\n"
" }\n"
" /Common/hodcdcgw02:389 {\n"
" address 10.6.15.22\n"
" priority-group 3\n"
" }\n"
" /Common/hodcdcgw04-1:389 {\n"
" address 10.6.15.207\n"
" priority-group 3\n"
" }\n"
" /Common/wkdcadrw02:389 {\n"
" address 10.6.66.21\n"
" priority-group 1\n"
" }\n"
" }\n"
" min-active-members 1\n"
" monitor /Common/bmdp_tcp \n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")