import Foundation
let pattern = #"^\s{8}/.*?(/.*?)?/(.*?):\d+\s{$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ltm pool /Common/ActiveDirectory_Pool {
members {
/Common/hodcdcgw01:389 {
address 10.6.15.21
priority-group 3
}
/Common/hodcdcgw02:389 {
address 10.6.15.22
priority-group 3
}
/Common/hodcdcgw04-1:389 {
address 10.6.15.207
priority-group 3
}
/Common/wkdcadrw02:389 {
address 10.6.66.21
priority-group 1
}
}
min-active-members 1
monitor /Common/bmdp_tcp
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)