use strict;
my $str = 'ltm pool /Common/ActiveDirectory_Pool {
members {
/Common/hodcdcgw01:389 {
address 10.6.15.21
priority-group 3
}
/Common/hodcdcgw02:389 {
address 10.6.15.22
priority-group 3
}
/Common/hodcdcgw04-1:389 {
address 10.6.15.207
priority-group 3
}
/Common/wkdcadrw02:389 {
address 10.6.66.21
priority-group 1
}
}
min-active-members 1
monitor /Common/bmdp_tcp
}';
my $regex = qr/^\s{8}/.*?(/.*?)?/(.*?):\d+\s{$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}