import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s{8}/.*?(/.*?)?/(.*?):\\d+\\s\\{$";
final String string = "ltm pool /Common/ActiveDirectory_Pool {\n"
+ " members {\n"
+ " /Common/hodcdcgw01:389 {\n"
+ " address 10.6.15.21\n"
+ " priority-group 3\n"
+ " }\n"
+ " /Common/hodcdcgw02:389 {\n"
+ " address 10.6.15.22\n"
+ " priority-group 3\n"
+ " }\n"
+ " /Common/hodcdcgw04-1:389 {\n"
+ " address 10.6.15.207\n"
+ " priority-group 3\n"
+ " }\n"
+ " /Common/wkdcadrw02:389 {\n"
+ " address 10.6.66.21\n"
+ " priority-group 1\n"
+ " }\n"
+ " }\n"
+ " min-active-members 1\n"
+ " monitor /Common/bmdp_tcp \n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}