#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z]+(?:(?:, |-)[A-Za-z]+)*$"
Local $sString = "A" & @CRLF & _
"Az" & @CRLF & _
"A-z" & @CRLF & _
"A-z, By" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Латиница верхний нижний регистр ([A-Za-z])" & @CRLF & _
"Пробел, запятая, тире." & @CRLF & _
"Строка начинается и заканчивается с литеры (любой)." & @CRLF & _
"Тире только между литерами." & @CRLF & _
"Запятая только перед пробелом после литеры"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")