package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z]+(?:(?:, |-)[A-Za-z]+)*$`)
var str = `A
Az
A-z
A-z, By
Латиница верхний нижний регистр ([A-Za-z])
Пробел, запятая, тире.
Строка начинается и заканчивается с литеры (любой).
Тире только между литерами.
Запятая только перед пробелом после литеры`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}